読者です 読者をやめる 読者になる 読者になる

べるべる研究日誌

なんでもやる系エンジニアの日々

MogrelとRuby1.8.6

Ruby

前から懸案だったOSXのRubyを1.8.6にアップデート。参考にしたのはこちら。

Mac OSX の、Ruby を1.8.4にアップデートしつつ、Railsも1.1.4に - Goodpic
Mongrel 動いた - Goodpic

(無謀にも)readline入れずにmakeしたら案の定rails実行時にコケル。Ruby起動できても安心しないこと。fink使いなので、「--prefix=/sw」としておいて/sw以下にインストールしたところが違いかな。とりあえず、サクッと。gemも入れ直し。

gem install mongrel

でインストール。この場合ちゃんと/sw/bin/以下にmongrel_railsが入って実行確認。これでまじろうが使える。

昔からfink派なんだけど、portsとどっちがいいんだろう...。